Problem: OBD2 adapter messes up CAN bus?


#21

Yes, I’d say it is probably from the Waylens OBDII dongle.
Many people on the forum are having issues before and after the latest FW updates.
I think everyone is waiting on feedback from tech support/forum mod on a new FW revision.
On my friends ZL1 Camaro he was getting several codes and he’d clear and they would come back until he removed the Waylens dongle.


#22

Is anyone still having issues since updating to 1.7.03?


#23

Well, If anyone else is still following this. On 1.7.03, it worked fine for about 4 Start. The issue returned and I removed the OBD dongle. I contacted Support and they recommended that I simply remove the OBD dongle and then place it back and that it should clear, they also mentioned to check the camera for any errors on the screen.


#24

My friend did the other day using the latest FW 1.07.03 but not sure what codes that were showing up.
He’s running the camera on his Chevrolet ZL1 Supercharged LS Camaro and once he removed the OBD dongle they codes went away. Plugged back in then codes came back.
Not sure what his latest status is, I’ll have to contact him to see if they keep coming back still, even after clearing them.
Previous to the latest update no problems. So there are for sure some bugs with the latest.


#25

Hi David,
Did you friend chose to clear the error code when he saw it after plugging his OBD back? I suggest him taking a pic of the error code and send it to us or paste it here. Generally, for some type of codes, it won’t appear after several times of clearing.
Thank you.


#26

I think most of his issues have cleared up.
One problem was that another gauge he had plugged into a Y adapter to his OBDII was causing some errors that he was unaware of. Then by removing the adapter and other gauge and just the Waylens OBDII adapter plugged in I think he said he was only getting 1 code now.
Not sure which one.
I’m sure he’ll message you soon.
Thank you for the help and reminder!


#27

Count another one with a problem here. I just upgraded to the latest firmware yesterday. I had skipped 1 or 2 versions of the firmware and had no DTC code ability previously. This is on a 2013 Subaru WRX.

Driving after upgrading, my dash went nuts as the OBD adapter upgraded. Now my car will not start up without 3 or 4 tries if the adapter is plugged in, and it always throws a code for Vehicle Communication Bus problem. Also feel like the throttle response has changed (seems weird but I have stalled the car 3 times in the last 2 days and I haven’t stalled in a long long time before that, cruise control also stuttered weirdly this morning which it’s never done before).

Take the adapter off and the car starts right up (haven’t driven it with it detached yet).

Probably going back to the last version of the firmware I had on there because this is ridiculous that it can screw with my car. I would really appreciate seeing branched versions of the firmware going forward where one has none of this DTC stuff in it whatsoever. I have no use for it, I have other tools for that if I need them, and they don’t make my car not start up.

Questions about rolling back the firmware - A> If I do the same process as upgrading, will it successfully install the older version? B> Will it roll back the firmware on the OBD adapter as well and remove all of this craziness?


#28

Count me in as another person that has seen issue.

As I mentioned in that thread, the issue happened a few minutes after I got on the road (during Monterey Car Week) leaving my car stuck in 7th Gear w/ no throttle due to a bunch of warnings popping up! It literally happened shortly after I received an notification to update the Waylens OBD II unit and completed the update.

Finally figured out it was the Waylens OBD II unit after multiple restarts of the car.

No way I will be party to Waylens using customers and their cars as their test bed. This happened on a mountain road while driving a very expensive car.


#29

Do we have a solution to this? I’ve gone through this a few times with the current firmware as well as the prior one on a 2015 WRX STI. U0073 code. Every single warning light is on or flashing on the dashboard, I cleared the code, removed the OBD adapter. Car fails to start. After 3 or 4 tries it finally starts, throttle response is affected. It’s now running just fine without the OBD adapter, which makes it pretty pointless to even use/own the camera.


#30

FYI the problem went away on my WRX once I turned off the ability for the camera to read codes from the settings menu, disconnected the OBD adapter, drove around for a day without it connected, and then reconnected it. No recurrence of the startup problems, code, lights, or throttle issues since with the adapter plugged in.

Also glad to hear I wasn’t imagining the throttle response issue.


#31

Sweet! Will try that. I have a track day coming up and was looking forward to using it. Thank you!!!


#32

Problem is still there with latest firmware. I’ve turned off “the ability for the camera to read codes” as suggested but still no luck.


#33

Same here. Stopped using the OBD adapter and all issues stopped. Now I feel like I have an overpriced GoPro :joy:


#34

From our testing and observations, there hasn’t been any case that a user’s car reports a problem really existing that is caused by our OBDs adapter. However, there are cases that some users’ cars report false alarms caused by the OBD2 adapter. And very few cautious users may stop driving when seeing those alarms.
The false alarms are most likely to happen when the camera is trying to updating the OBD firmware, ironically the process of updating will mess up the CAN bus and thus leave some random error codes for the cars to detect and report. Since we can do little to improve the compatibility of the updating process, we manually clear the error codes when the update completes. However, a few car models might still record the error codes and report them, which is determined by the cautiousness of the car models’ sw design. Since the random error codes don’t reflect the real problems and are cleared after the update. Usually the car models will stop popping or lighting the alarms after several power cycles(for my subaru, 3 times of engine starts/stops).
If your car model keeps showing the warning messages with OBD2 connected, please email me your model’s info and we will inform our OBD2 vendor to have a further diagnose which may take a long time.
Btw, we seldom updates the OBD2 firmware(til now, only once), especially after realizing the update process may cause some unnecessary panic. However we are open to send our testing OBD2 fw to those volunteers who fully realize the situations of the OBD2 adapter to have a try.
Thank you!


#35

I drive a Subaru as well. 2015 STI. The issue that I had the last time, before I stopped using the OBDII adapter, was that the car went onto limp mode as soon as all the warning lights came on. Once I shut the engine off, I waited about a minute and tried starting the engine back on and it wouldn’t start. After a few tries, it started. The warning lights were still on but the car was running fine. Once I got home, I turned the car off and back on a few minutes later and everything went back to normal. I’m currently using the latest firmware. I didn’t clear the code on the camera itself though because I wasn’t sure what was going on. I’ll give your process a try for the next few days and see how it works.


#36

I’ve only encountered Waylens-induced warning lights a few times with my 2014 BRZ (hey, Subaru club in this thread!), but when it did occur the car was placed in a limp mode as well with limited throttle response until I was able to clear the codes. While the trouble codes may indeed be false, the car’s reaction to them is very real - and particularly annoying since most of those problems where encountered while in an autocross grid area.

For what it’s worth, I actually saw the same problem much more regularly before I started using the Waylens. That was with a variety of datalogging apps (Harry’s Lap Timer, Track Addict, Torque) connected to the car via an OBDLink LX adapter, and seemed to occur in scenarios where I had left the logging running when I turned off the car and started it back up again a few minutes later. Pulling the code revealed it to be U0073, which points to a control module communication fault - and it’s apparently a not-infrequent issue. I guess the car gets grumpy if an ODB adapter is trying to talk to it before it’s good and awake. The problem went away entirely once I got in the habit of shutting off the datalogging apps prior to killing the engine.

The infrequent Waylens issues seemed to follow a similar pattern. I never turn off the camera manually (instead letting it time out automatically after ten seconds), but the warning lights might appear if I started the car again very shortly after turning it off. Again, I now make sure that the camera is completely powered off before I start the car up and I haven’t encountered it again.

(I did experience the same fault when I started driving without realizing that the OBD firmware was being updated, but it sounds like that’s kind of expected.)

I don’t know if this jives with what anyone else has experienced, but figured I’d mention it since it seemed to be a topic of discussion here.


#37

Had another weird occurrence of this, this time in our Outback. Hooked up the camera and OBD adapter and drove around all day, went and did Rallycross the next day, drove all the way home, everything worked fine. Took the camera out to put it back in my WRX and forgot the OBD adapter. Next day my wife is freaking out because her dash is going nuts. Removed the adapter, restarted the car several times, problem went away.

At first I thought maybe it was b/c the adapter couldn’t see the camera, but then I realized that most of the first day the camera was off because we couldn’t get the sticky mount to stay stuck.

Seems like the adapter and Subaru software don’t like each other very much, though I have not had the problem again in my WRX.


#38

@VincentSun my car is a stock 2010 Acura TL SH-AWD Tech. I still get error codes within minutes of plugging in the Waylens OBD2 adapter.

Btw when did you last update the Waylens OBD2 firmware? I had no problem until April 2017. I’m open to testing any pre-April 2017 firmware or newer beta ones, as long as it works with the current Android app.

As mentioned in my OP, I’ve the Android Torque app and a cheap $20 no-name ebay bluetooth OBD2 adapter that I use to check and clear CAN bus codes. I used to have that OBD2 adapter plugged in all the time, and it has never caused any CAN bus error, so I think my car isn’t particularly picky about an OBD2 adapter reading from the CAN bus…


#39

@cm1 I have sent you a message to revert the OBD firmware. You need to update your camera manually, btw.
https://support.waylens.com/faq/15/2486


#40

Thanks @VincentSun for the old OBD firmware! So far so good! No more CAN bus errors and the camera is reading the OBD data (like engine rev) fine.

Looking forward to you branching the firmware and the adding newer features (eg. performance testing) to this old OBD firmware…