Track timer mode is very unreliable


#1

I bought my Waylens Horizon to simplify recording track laps, since I used to use an app + external GPS + bluetooth OBD-II scanner, which is all built into one system in Waylens.

However, having used it several times now at the track, and missing most of the footage I’d like to have, I’m giving up on it.

The reason is that if you put it in track mode, it’s supposed to trigger and start recording when you pass the start/finish line. It won’t start recording at all until you’ve crossed the line for the first time, but the problem is that it fails to notice that you’ve crossed it about 2/3 of the laps. Sometimes, I’ll be doing laps for 15+ minutes before it realizes that I’m lapping.

I think it’s due to a bug with how the camera computes whether it’s crossed the line. I recorded its screen with my trusty GoPro while I was driving, and as I approach the start/finish, it gives me a distance to it in yards, counting down as I approach. It’ll look like 18yd, 10yd, 3 yd…, and then is when the bug happens, it’ll start counting up … 5yd, 10yd, etc. What happened is that I crossed start/finish between GPS fixes, and the camera triggers when you’ve crossed within a yard or so. I’m going down the track ~120MPH when I cross start/finish, so the fixes are far apart. In one lap, where I was all alone on the straight, I crossed start/finish at about 30mph, and the camera noticed that I crossed the line because it had a fix at 0 yards.

So, I work with GPS and build maps for a living. If any Waylens developers are reading this, the correct way to detect this start finish line is to do a simple calculation - if two fixes are on opposite sides of the start/finish line, then it’s been crossed, don’t base this on absolute distance, as it will be flakey. It’s a simple fix.


#2

Hi @marcinr - thank you for the feedback! We do appreciate it and I can tell you, our engineers take feedback seriously and most of the time we’re able to implement changes and fix bugs with firmware updates.

Were you using the Lap Timer in manual mode or did you select a pre-loaded track?

@VincentSun can you take a look at this issue?


#3

I selected a pre loaded track, since manual mode requires pressing the little button each time you cross start/finish, and that’s more mental bandwidth than driving at the edge than I have.

I do have some Waylens videos where I do several laps and there are no lap markers. I can send them to you for investigation. Sadly, most of my video is simply missing since it didn’t get recorded, since the camera never noticed the initial start/finish crossing.

If your camera does miss start/finish crossings, it’s also easy to add them back in the studio by doing the same kind of line check I mentioned. For inspiration, check out the excellent program “Race Render 3”. I can upload my waylens telemetry there, and it fixes it up. It can’t back-fill missing video, though :slight_smile:


#4

I have the same problem. I used it at the track a couple of times and the auto mode is very inconsistent. For me it usually recognizes the first lap when I cross the start line, but never the subsequent laps. I usually end up with a 20+ minute lap and no useful data.

Using manual mode works a bit better. The camera still does not recognize the start line after you cross in every lap, but you do see the data in the app.

I now have another problem. I have a ton of footage that I captured from the track but I can’t download as the app doesn’t recognize it. I can see the files in the memory card but the app doesnt display the video.


#5

I’ve been in contact with support over this.

I also had the same problem about missing video (I posted another thread about it). The reason is that some of the clipinfo files got deleted. Do not use your memory card anymore, since they can be recovered if they’ve not been overwritten.

Download TestDisk (https://www.cgsecurity.org/wiki/TestDisk_Download), and use it to navigate to your 100TRANS/clipinfo directory. Find all the files which have been deleted, and undelete them. You have to undelete them to another place, not onto the memory card. Once they’re undeleted, copy them into the same place with the rest of the clipinfo files and they’ll become available.

You can also use other software to split your 20 minute laps into actual laps. Check out RaceRender 3. You can export the entire telemetry from the session to a CSV file, and export the video from Waylens Studio, then when you import them into RaceRender 3, you can split it into laps and generate video overlays via that tool. It’s significantly better than Waylens Studio.


#6

I tried last night and it worked. Several of the files had the .temp extension and I was able to download the videos after renaming them to .clip.

Thanks for the info!


#7

I think what you’ve mentioned here happened to me. However, I shared a bug report via Waylens Studio and they said it looked like I accidentally pressed the manual lap timing (remote click) mode… which I doubt.

In my memory, the Horizon screen would show “[x] yards” to the start/finish line and still show 0 yards or something else when I come back into pit.

While I can’t be sure this was the case for me, I’d love for additional reliability to be built into the lap detection. If there is opportunity here to improve it, let’s do it! I have another 2-day event coming up October 6-7, would love to have reliable footage.

In the meantime, I will be a bit more careful with my placement of the external GPS unit. I have it mounted to a magnetic mount on my windshield. I seem to have slightly better luck when some of the external GPS’s back is facing the sky directly.


#8

The issues you have seen are very consistent with what I experienced as well. This past weekend I was able to get laptimer to work on auto mode only once. I tried 3-4 times and always used the same procedure. Every other time I received a 20+ minute lap. I can’t explain why it works sometimes and others will not.

Manual works for the most part but you lose some split data. The fact that I could use laptimer automatically was the selling point for me and it is disappointing not to be able to use it consistently or to have to pit to switch from auto to manual so I can get some data.


I don’t seem to have access to post a reply, so editing my post to reply to the forum moderator re manual mode:

It does not work as well. In theory it will do that but it doesn’t work. It stays in lap 2 until you finish. In the app you see the individual lap times but not in the camera.

Also, I am going 110+ mph at the front straight the places I am driving and my focus is on the next turn and everything around me. Manual mode creates a distraction and the intent of the Waylens camera for me is to set up before I get on track and don’t worry it while on track.

Also, you can’t switch from auto to manual. Whenever I am trying auto and it doesn’t work I have to pit to switch losing at least a couple of laps of good data and time.


#9

Same problem here. Lap timer worked properly maybe once. Pre-loaded tracks.

Don’t want to hassle with manual mode on track.


#10

@kjcalhoun1 - I am interested to know how the Lap Timer’s manual mode is difficult to use? You can hit the remote once to start and end the run. If the preloaded tracks are not working correctly as some have said and you are missing laps, wouldn’t the manual mode be a great alternative?


#11

No, the manual mode is not difficult to unset, however, when you’re doing laps at the track, you want to see lap times. You don’t have that in manual mode. When you’re also driving very intensely, pushing that button is the last thing you want to think about, so it’s an unnecessary distraction. I bought a Waylens precisely because of this track mode, and it’s disappointing that it doesn’t work. I’ve gone back to using a GoPro + OBD-II reader + external GPS + my cell phone. It’s a pain to set everything up together, which is why the Waylens was such a nice alternative.


#12

@marcinr - the manual mode will give you lap times on the camera, am I misunderstanding something here?

Essentially all you need to do is press the button once to start, and you can stop the camera at any time to end the lap timer mode, not necessarily as soon as you cross the finish line.


#13

Oh, I didn’t know that. I’ll try it again next time, then. Thanks.


#14

I have an angle - the manual mode is not preferred because:

(1) [unproven - is this true?] the track map would not display if we use manual mode, only lap times
(2) Me pressing a button is not as accurate position wise as the actual location - I’ll likely have set the start/stop location to somewhere before or after the actual start/stop

Manual mode in Waylens studio after recording would be great. If my lap timer failed to record start/stop, I’d like to be able to input the location on a map. Garmin VIRB does this and works well, but it’s not the ideal method.


#15

Hi @KenYip - Thanks for your feedback. We’ve received some feedback from multiple users and our Horizon project engineer is reviewing and looking into further development options!


#16

Pretty disappointed in the Lap Timer Functionality. I set the camera to run at (New York Safety Track Uptown)…All of my sessions show video with an overlay showing “Record” as in record lap with one listed with times 12:00 to 22:00 minutes. Ridiculous. This functionality has worked maybe three times out of ten since I’ve owned it …Not what I expected from a $500+ camera

Please, note I’m running the latest firmware.


#17

Could you open the sd card in Waylens Studio, then drag this track to the edit area. Then send the log file from Waylens Studio’s menu – Help – Feedback – Click Send button.
I will check it accordingly, thanks.


#18

Thanks, I’ve just sent it.


#19

Support went over my logs and state the following as others have mentioned. I’m 99% certain I only select the “Closed” Lap Timer icon everytime I start. I can’t see how this has happened to me at least half a dozen times out of ten events unless there is a bug, which i’m assuming is the case here.


#20

Here’s something weird: I noticed that one or more times, the positions of the closed and split timer icons switched. I remember one time, the closed icon was on the right… are we onto something?