Waylens OBD II Update Caused ECU Error Codes While Driving


#1

The latest update to the Waylens OBD II plug has changed the behavior of the Waylens plug, and it caused my car to go into Limp Mode on the Freeway! Incredibly dangerous what Waylens is doing. I am concerned they are just using customers as a test bed. I’m massively disappointed, and I have stopped using my OBD II plug. I refuse to plug it back in, and therefore the camera is pretty pointless to me.

There’s no way in hell I am plugging it back into my car’s port to receive even a new update and risk my car behaving like that again.

Problem went away 100% as soon as I unplugged it.

This on top of the incredibly poor windshield mount design is really disappointing. Makes going back to my GoPro almost a sure thing.


Problem: OBD2 adapter messes up CAN bus?
#2

I had a similar situation. Check engine light and overall freaking out dashboard. Definitely a MAJOR concern. Worry it could affect my vehicle.


#3

Which car model do you drive?


#4

Wow, I am sorry to hear about your experience. I am still having issues with the OBD reader myself. 2011 Chevy Cruze.

Did you get errors when you first started your car as well?


#5

Old thread but just updating. I stopped using the camera in my 16 Durango RT with the OBD dongle. Occasionally still use it just as a regular dashcam. Will probably stop using it altogether now that I got the 360 camera.


#6

I set up the camera in my '04 Ferrari Challenge Stradale. With the OBD transmitter plugged in, the car would not start. It cranked and acted like the alarm system was armed, but it had been disarmed.

Removing the OBD transmitter resulted in the car starting normally. Hopefully there will be a fix, because I wanted the extra data for track days.


#7

Hi @Ingenere, there are a few OBD-II firmware settings in the debug menu of the camera, you can try the other two firmware options under the iOBD2 menu (reboot camera before testing). You can also try disabling the Diagnostic Trouble Code (DTC) reader from the system settings menu. Let us know if that helps. I’ve installed in a few Ferraris before and had mixed results with the standard OBD settings.


#8

I was able to navigate to the debug menu, but I have no idea what to do and there doesn’t appear that there are any directions on debug procedures.


#9

If the DTC reader functionality causes issues on some cars, perhaps it should be disabled by default. It’s a very unnecessary feature that isn’t in the core features of the camera. I believe a lot of us car enthusiasts have our own devices for reading and clearing codes anyways.


#10

@Ingenere - You may want to try disabling the DTC reader first. As far as the debug menu goes, there are 3 options listed for the OBD-II firmware. What you’ll need to do is navigate to the iOBD2 settings menu, select one of the options, reboot your camera and test to see if there any error codes still popping up. If so, go back to the debug menu and test a different firmware option.

@KenYip - the DTC reader rarely causes issues in vehicles, we’ve only seen a couple of instances where errors pop up.


#11

I’m having an issue with the OBD2 plug tripping Check Engine, Service Active Handling and Service Traction Control in my 2008 Corvette. Worked fine for 2 years, just having this issue this year. Even took it to the dealer who advised me not to leave anything plugged into the car’s ODB2 port.

I’m going to try disabling DTC in the camera settings first. I also see how to change the iOBD2 firmware versions thanks to the earlier post. Will try this next if still having issues. Very frustrating since it limits the performance of the car when it happens.


#12

@glennh215

I had a similar issue with my 2013 Camaro, and disabling the DTC has worked for me. Before this option was told to me, I did some digging to try and figure out what was the issue.

I took my car to the dealership, they said they were able to see that there was a network issue where the devices were not able to communicate with each other, but that the issue cleared rather quickly. A full power cycle for all of the control modules solves this issue. You can either wait for the power to come off of them, which for my car meant leaving it parked and walking away for 5-10 minutes. What also worked was pulling the battery leads, but then you have to reset a lot of stuff (I only did that on once).

So, like I said after I disabled the DTC functionality I have not had this error happen again. But if you continue to get this error, please either post again here or contact support@waylens.com and we’ll be happy to help.